中望CAD

快速链接

搜索结果建议

中望CAD/CAM提速教程之模板定制

经验技巧 2014-08-15 15:08:51 4920
返回
       “我们公司的加工中心都是固定的,加工的工件是有规律的,工件材料和加工工艺方法也是有规律。同样,我们选用的刀具、转速和进给也有规律,那么,在CAD编程时,如何减少选择这些加工参数所带来的重复劳动呢?”这是许多CAD用户的心声。它的答案是肯定的,作为一款高性价比的CAD/CAM软件,中望3D可以轻松做到。中望3D通过强大的模板定制功能,帮助你大幅减少CAD设计过程中的重复劳动,加快CAD编程速度,提升企业竞争力。

       现在就来看看中望3D是如何做到的。

       1.新建模板文件

       首先,我们需要新建一个加工模板文件,安装程序默认是没有加工模板的。

       (提示:同类型的模板文件可以创建多个.)

       Step1.启动中望3D,点击菜单栏:文件→模板,进入到如下界面。(图一)

中望CAD/CAM提速教程之模板定制

(图一)

       Step2.点击创建新对象,进入到如下界面。在类型中选择加工方案,接着给定一个唯一名称。(图二)

       (取模板名称时,我们可以以部门或者零件类型等有实际意义的词来划分,这样直观方便使用.)

       Step3.点击确认后直接进入到加工模块,点击保存。(图三)

       (这里建议大家,在每次完成一段工作后,都保存一下文件,养成一个良好习惯,尽量避免不必要的损失.)

中望CAD/CAM提速教程之模板定制

       2.输入刀具

       在这里,我们只把常用的刀具(亦可指加工中心上固定的刀具)输入到模板中,这样便可直接取用,为避免刀具过多而影响选用的效率,建议将其它刀具写入刀具库中。

       Step4. 点击菜单栏:工具→输入对象,进入到如下界面。打开文件刀具.csv,输入已经做好的刀具。(图四)

       可以看到图四的文件类型选项,.csv和.txt。这两种类型都是纯文本文件,都可以用EXCEL来编辑,这里及下面我们都采用.csv的文件类型。

       Step5.此时,在工序中,点击刀具选项,我们直接进入到刀具列表,而非刀具库,快速选用。(图五)

       我们选择的工序类型和刀具类型是相对应的,例如:我们选择铣削的工序类型时,在刀具列表中就不会出现钻削的刀具。

中望CAD/CAM提速教程之模板定制

       3.输入转速与进给

       Step6.点击菜单栏:工具→输入对象,进入到如下界面。打开文件转速与进给.csv,输入已经做好的转速与进给。(图六)

       (提示:我们的刀具、转速与进给以及设备文件都是.csv文件,仅内部参数有所区别)

       Step7.进入工序参数里的速度、进给项,点击靠下的从其他表复制值,此时,直接进入到转速进刀速度表,而非速度与进给库。(图七)

       (注意:转速进刀速度表不会与工序类型相对应,但是要注意区别工序的类别是粗加工还是精加工。另外,这些列表都是以阿拉伯字母升序为原则排序。)

中望CAD/CAM提速教程之模板定制

       4.输入设备

       这里的设备是指我们的数控机床。设备的选用在一个零件的加工编程中只需选一次,不会像刀具和转速与进给的选取那么频繁,但设备内的参数选项更多,重复新建会更麻烦,而且数控机床对于一个企业来说又是一个极为固定的生产设备。所以有必要在模板中先设置好,在CAD编程时直接调用。

       Step8.点击菜单栏:工具→输入对象,进入到如下界面。打开文件设备.csv,输入已经做好的设备。(图八)

       Step9.点击方案管理器的设备,直接进入到设备列表,可以看到设备已经输入模板中,从中选取你需要的机床。(图九)

中望CAD/CAM提速教程之模板定制

       5.工序参数的保存与调用

       在工序中,参数是一个非常重要的选项,包括切削参数、极限参数、进退刀参数、后处理参数、显示参数、进给参数等。进给参数前面已经介绍了更简便的方法,这里不在重复。

       需要区别的是,前面采用的方法都是指定输入文件。在这里,我们需要进入到工序参数的界面,可以看到在靠下一行,有一个保存按钮,设置好我们常用的参数后,点击保存。那么下次在调用这种工序时就是你目前保存的参数。

       保存位置可以自己指定,但是调用位置暂不支持指定,默认为个人用户目录下,如图十。

中望CAD/CAM提速教程之模板定制

(图十)

       (提示:1.个人用户目录一般为 C:Documents and SettingsuserApplication DataW3D 2011 Chs,需要注意的是 Application Data 这个文件夹一般是隐藏文件,需要手动显示方可将参数文件保存到默认位置。

       2.不仅仅是在模板中可以保存工序参数,在其它中望3D文件中的加工环境下都可以保存工序参数文件,同时也不会违背提示3的原则。

       3.不支持同一种工序有不同版本的参数文件,后一保存会覆盖前一保存,该文件名后缀为.cfg。)

OK,到此我们已经完成了CAD模板的个性化定制,接下来就开始体验高效率的CAD编程模式吧!

       附:如何创建、修改.csv文件

       前面只讲到如何使用.csv的文件,现在来介绍它是如何创建与修改的。.csv文件可以用Excel打开,也可以用Excel来创建、修改,从而可以利用Excel强大的功能批量的、快速的创建加工数据库。

       1.新建一个Excel文件,输入数据,另存,选择保存类型为 CSV(逗号分隔)(*.csv) ,如图十一:

       2.在.csv文件中,数据的格式是怎么的呢?

       我们可以看到下面两张图,数据内容由两部分组成。首先第一行是变量名称,然后第二行及以后行数输入的不同刀具名称相对应的值,转速与进给和设备文件同理。(图十二)

       3.如何获取第一行的变量名称呢?

       第一次获取变量名称的时候,我们可以通过在一个包含刀具、转速与进给、设备的加工文件中,点击菜单栏:工具→输出对象;第一步,选择类别;第二步,选择项确定。如图十三:

中望CAD/CAM提速教程之模板定制

       在输出位置查看刚刚输出的.csv文件,便可看到第一行的变量名称,此时,我们可以根据加工需求去新建、修改、删除第一行以外行的值。

       超清CAD教程演示视频链接:http://v.youku.com/v_show/id_XMjk1NjQ2MDYw.html

       原文地址:https://www.zwsoft.cn/support/zw3d


中望软件技术

中望CAD

商城客服

商城客服

产品购买、商业合作等
操作答疑、技术指导等
4007-182-588
商城购买、发货发票等